re = /^(?:\/[^\/\s]+)+Trash[^\/]*$/m
str = '/a/b/.Trash
/a/b/.Trash+other words -> good
/a/b/.Trash -> good
/a/b/.blahTrash -> good
/a/.Trash -> good
/a/b/.Trash/c/d -> bad'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end