const regex = /^(?:\/[^\/\s]+)+Trash[^\/]*$/gsm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\\/[^\\\/\\s]+)+Trash[^\\\/]*$', 'gsm')
const str = `/a/b/.Trash
/a/b/.Trash+other words -> good
/a/b/.Trash -> good
/a/b/.blahTrash -> good
/a/.Trash -> good
/a/b/.Trash/c/d -> bad`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}