import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\/[^\\/\\s]+)+Trash[^\\/]*$";
final String string = "/a/b/.Trash\n"
+ "/a/b/.Trash+other words -> good\n"
+ "/a/b/.Trash -> good\n"
+ "/a/b/.blahTrash -> good\n"
+ "/a/.Trash -> good\n"
+ "/a/b/.Trash/c/d -> bad";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}