# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?=.*?[1-9])[0-9\\,\\-]+$//;t' <<< "90,91,90-200,90,900-9000"