use strict;
my $str = '90,91,90-200,90,900-9000';
my $regex = qr/^(?=.*?[1-9])[0-9\\,\\-]+$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";