re = /^(?=.*?[1-9])[0-9\\,\\-]+$/
str = '90,91,90-200,90,900-9000'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result