using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*?[1-9])[0-9\\,\\-]+$";
string substitution = @"";
string input = @"90,91,90-200,90,900-9000";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}