#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".(?![^\[]*\])|\["
Local $sString = "Will you [B] meet me [A] in the [EKSA] end"
Local $sSubst = "."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)