re = /.(?![^\[]*\])|\[/
str = 'Will you [B] meet me [A] in the [EKSA] end'
subst = '.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result