$re = '/.(?![^\[]*\])|\[/';
$str = 'Will you [B] meet me [A] in the [EKSA] end';
$subst = ".";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;