using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".(?![^\[]*\])|\[";
string substitution = @".";
string input = @"Will you [B] meet me [A] in the [EKSA] end";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}