use strict;
my $str = 'Will you [B] meet me [A] in the [EKSA] end';
my $regex = qr/.(?![^\[]*\])|\[/p;
my $subst = '.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";