using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\s*[=]\s*\d+)\,\s?(?![^\<]*\>)";
string substitution = @"\n";
string input = @"<product_11,product_12>=5,product_1,product_2,product_3=1,product_9=3,<product_5,product_6>=10,product_11,product_12,product_13,product_14=20";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}