const regex = /(?<!\s*[=]\s*\d+)\,\s?(?![^\<]*\>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!\\s*[=]\\s*\\d+)\\,\\s?(?![^\\<]*\\>)', 'g')
const str = `<product_11,product_12>=5,product_1,product_2,product_3=1,product_9=3,<product_5,product_6>=10,product_11,product_12,product_13,product_14=20`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);