re = /(?<!\s*[=]\s*\d+)\,\s?(?![^\<]*\>)/
str = '<product_11,product_12>=5,product_1,product_2,product_3=1,product_9=3,<product_5,product_6>=10,product_11,product_12,product_13,product_14=20'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result