use strict;
my $str = '<product_11,product_12>=5,product_1,product_2,product_3=1,product_9=3,<product_5,product_6>=10,product_11,product_12,product_13,product_14=20';
my $regex = qr/(?<!\s*[=]\s*\d+)\,\s?(?![^\<]*\>)/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";