import Foundation
let pattern = #"(?<!\s*[=]\s*\d+)\,\s?(?![^\<]*\>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<product_11,product_12>=5,product_1,product_2,product_3=1,product_9=3,<product_5,product_6>=10,product_11,product_12,product_13,product_14=20"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)