#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^([\s\S]{9}((?=\s)\s|[^\s]*)).*"
Local $sString = "this is a longish string of test" & @CRLF & _
"another line just as example" & @CRLF & _
"a l1ne w!th d.ff.r.nt wh1t3sp 4 c e 5 ..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")