using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\s\S]{9}((?=\s)\s|[^\s]*)).*";
string input = @"this is a longish string of test
another line just as example
a l1ne w!th d.ff.r.nt wh1t3sp 4 c e 5 ...";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}