const regex = /^([\s\S]{9}((?=\s)\s|[^\s]*)).*/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\s\\S]{9}((?=\\s)\\s|[^\\s]*)).*', 'igm')
const str = `this is a longish string of test
another line just as example
a l1ne w!th d.ff.r.nt wh1t3sp 4 c e 5 ...`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}