re = /^([\s\S]{9}((?=\s)\s|[^\s]*)).*/im
str = 'this is a longish string of test
another line just as example
a l1ne w!th d.ff.r.nt wh1t3sp 4 c e 5 ...'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end