using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)UPDATE[ \t\n]{1,}(fact)(.*)\n(from)?([ \t\n]{1,})?(.*)?\n*set[ \n\t]{1,}(coloana)[ \t\n]*=[ \t\n]*(ifnull\(\s*)*([\w\d]*)([\ ,'\w\n\t)(\n=.]*);";
string input = @"update fact,x2,asdasjsdjbmfeweoewo
from asdas,asaskdvd
set coloana = ifnull( ifnull( col2,'Test'), 'Test2')
where c = c.s.
and asdsa = asda.asda;
UPdate fact,x2
set coloana = ifnull(col2,'Test')
where c = c.s.;
update
fact,x2
from
asdas
set coloana = ifnull(col2,'Test')
where c = c.s.
and asdsa = asda.asda;
update fact,x2
from asdas
set coloana = (select x from y where x.fg = x2.asfds)
where c = c.s.
and asdsa = asda.asda;";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}