// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)UPDATE[ \t\n]{1,}(fact)(.*)\n(from)?([ \t\n]{1,})?(.*)?\n*set[ \n\t]{1,}(coloana)[ \t\n]*=[ \t\n]*(ifnull\(\s*)*([\w\d]*)([\ ,'\w\n\t)(\n=.]*);").unwrap();
let string = "update fact,x2,asdasjsdjbmfeweoewo
from asdas,asaskdvd
set coloana = ifnull( ifnull( col2,'Test'), 'Test2')
where c = c.s.
and asdsa = asda.asda;
UPdate fact,x2
set coloana = ifnull(col2,'Test')
where c = c.s.;
update
fact,x2
from
asdas
set coloana = ifnull(col2,'Test')
where c = c.s.
and asdsa = asda.asda;
update fact,x2
from asdas
set coloana = (select x from y where x.fg = x2.asfds)
where c = c.s.
and asdsa = asda.asda;";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}