const regex = /(?i)UPDATE[ \t\n]{1,}(fact)(.*)\n(from)?([ \t\n]{1,})?(.*)?\n*set[ \n\t]{1,}(coloana)[ \t\n]*=[ \t\n]*(ifnull\(\s*)*([\w\d]*)([\ ,'\w\n\t)(\n=.]*);/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)UPDATE[ \\t\\n]{1,}(fact)(.*)\\n(from)?([ \\t\\n]{1,})?(.*)?\\n*set[ \\n\\t]{1,}(coloana)[ \\t\\n]*=[ \\t\\n]*(ifnull\\(\\s*)*([\\w\\d]*)([\\ ,\'\\w\\n\\t)(\\n=.]*);', '')
const str = `update fact,x2,asdasjsdjbmfeweoewo
from asdas,asaskdvd
set coloana = ifnull( ifnull( col2,'Test'), 'Test2')
where c = c.s.
and asdsa = asda.asda;
UPdate fact,x2
set coloana = ifnull(col2,'Test')
where c = c.s.;
update
fact,x2
from
asdas
set coloana = ifnull(col2,'Test')
where c = c.s.
and asdsa = asda.asda;
update fact,x2
from asdas
set coloana = (select x from y where x.fg = x2.asfds)
where c = c.s.
and asdsa = asda.asda;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}