package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(export[^(]*)(\(([^)]+)\))([^{]*)(\{([^}]+)\})`)
var str = `export default function something($123, something, wauw) {
function(random) {
return random;
}
}
export default function(something, wauw) {
}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}