// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(export[^(]*)(\(([^)]+)\))([^{]*)(\{([^}]+)\})").unwrap();
let string = "export default function something($123, something, wauw) {
function(random) {
return random;
}
}
export default function(something, wauw) {
}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}