import re
regex = re.compile(r"(export[^(]*)(\(([^)]+)\))([^{]*)(\{([^}]+)\})")
test_str = ("export default function something($123, something, wauw) {\n"
" \n"
" function(random) {\n"
" return random;\n"
" }\n"
"}\n\n\n"
"export default function(something, wauw) {\n\n"
"}\n"
" \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")