re = /(export[^(]*)(\(([^)]+)\))([^{]*)(\{([^}]+)\})/
str = 'export default function something($123, something, wauw) {
function(random) {
return random;
}
}
export default function(something, wauw) {
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end