const regex = /(?<!a)a(?=(?:aa)*(?!a))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!a)a(?=(?:aa)*(?!a))', 'gm')
const str = `abaabaaabaaaabaaabaaaaaabaababaaabaaaabaaaaaabaaaaabaaabaabaababaaabaaaabaaaabaabaaab`;
const subst = `c`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);