import re
regex = re.compile(r"(?<!a)a(?=(?:aa)*(?!a))", flags=re.MULTILINE)
test_str = "abaabaaabaaaabaaabaaaaaabaababaaabaaaabaaaaaabaaaaabaaabaabaababaaabaaaabaaaabaabaaab"
subst = "c"
result = regex.sub(subst, test_str)
if result:
print(result)