import Foundation
let pattern = #"(?<!a)a(?=(?:aa)*(?!a))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"abaabaaabaaaabaaabaaaaaabaababaaabaaaabaaaaaabaaaaabaaabaabaababaaabaaaabaaaabaabaaab"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"c"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)