$re = '/(?<!a)a(?=(?:aa)*(?!a))/m';
$str = 'abaabaaabaaaabaaabaaaaaabaababaaabaaaabaaaaaabaaaaabaaabaabaababaaabaaaabaaaabaabaaab';
$subst = "c";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;