re = /(?<!a)a(?=(?:aa)*(?!a))/m
str = 'abaabaaabaaaabaaabaaaaaabaababaaabaaaabaaaaaabaaaaabaaabaabaababaaabaaaabaaaabaabaaab'
subst = 'c'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result