#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(.*):(.*):(.*):(.*):(.*):(.*):(.*):(.*)$"
Local $sString = "I have the following text document:" & @CRLF & _
"" & @CRLF & _
"word1: word2: word3: word4: word5: word6: word7: word8 word9" & @CRLF & _
"" & @CRLF & _
"word1: word2: word3: word4: word5: word6: word7: word8 word9" & @CRLF & _
"" & @CRLF & _
"word1: word2: word3: word4: word5: word6: word7: word8 word9"
Local $sSubst = "$1,$2,$3,$4,$5,$6,$7,$8"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)