import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.*):(.*):(.*):(.*):(.*):(.*):(.*):(.*)$";
final String string = "I have the following text document:\n\n"
+ "word1: word2: word3: word4: word5: word6: word7: word8 word9\n\n"
+ "word1: word2: word3: word4: word5: word6: word7: word8 word9\n\n"
+ "word1: word2: word3: word4: word5: word6: word7: word8 word9";
final String subst = "$1,$2,$3,$4,$5,$6,$7,$8";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}