$re = '/^(.*):(.*):(.*):(.*):(.*):(.*):(.*):(.*)$/m';
$str = 'I have the following text document:
word1: word2: word3: word4: word5: word6: word7: word8 word9
word1: word2: word3: word4: word5: word6: word7: word8 word9
word1: word2: word3: word4: word5: word6: word7: word8 word9';
$subst = "$1,$2,$3,$4,$5,$6,$7,$8";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;