# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(.*):(.*):(.*):(.*):(.*):(.*):(.*):(.*)$"
test_str = ("I have the following text document:\n\n"
"word1: word2: word3: word4: word5: word6: word7: word8 word9\n\n"
"word1: word2: word3: word4: word5: word6: word7: word8 word9\n\n"
"word1: word2: word3: word4: word5: word6: word7: word8 word9")
subst = "$1,$2,$3,$4,$5,$6,$7,$8"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.