// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.*):(.*):(.*):(.*):(.*):(.*):(.*):(.*)$").unwrap();
let string = "I have the following text document:
word1: word2: word3: word4: word5: word6: word7: word8 word9
word1: word2: word3: word4: word5: word6: word7: word8 word9
word1: word2: word3: word4: word5: word6: word7: word8 word9";
let substitution = "$1,$2,$3,$4,$5,$6,$7,$8";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}