#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[0-4](?:\.5)?|5)$"
Local $sString = "0" & @CRLF & _
"0.5" & @CRLF & _
"1" & @CRLF & _
"1.5" & @CRLF & _
"2" & @CRLF & _
"2.5" & @CRLF & _
"3" & @CRLF & _
"3.5" & @CRLF & _
"4" & @CRLF & _
"4.5" & @CRLF & _
"5" & @CRLF & _
"5.5" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")