import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[0-4](?:\\.5)?|5)$";
final String string = "0\n"
+ "0.5\n"
+ "1\n"
+ "1.5\n"
+ "2\n"
+ "2.5\n"
+ "3\n"
+ "3.5\n"
+ "4\n"
+ "4.5\n"
+ "5\n"
+ "5.5\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}