package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[0-4](?:\.5)?|5)$`)
var str = `0
0.5
1
1.5
2
2.5
3
3.5
4
4.5
5
5.5
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}