$re = '/^(?:[0-4](?:\.5)?|5)$/m';
$str = '0
0.5
1
1.5
2
2.5
3
3.5
4
4.5
5
5.5
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);