const regex = /^(?:[0-4](?:\.5)?|5)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[0-4](?:\\.5)?|5)$', 'gm')
const str = `0
0.5
1
1.5
2
2.5
3
3.5
4
4.5
5
5.5
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}