import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^aaa accounting system default (\\n action-type |)start-stop(\\n |) group tacacs\\+";
final String string = "aaa accounting system default\n"
+ " action-type start-stop\n"
+ " group tacacs+\n\n"
+ "aaa accounting system default start-stop group tacacs+";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}