const regex = /^aaa accounting system default (\n action-type |)start-stop(\n |) group tacacs\+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^aaa accounting system default (\\n action-type |)start-stop(\\n |) group tacacs\\+', 'gm')
const str = `aaa accounting system default
action-type start-stop
group tacacs+
aaa accounting system default start-stop group tacacs+`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}