# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=[a-zA-Z])(?=[0-9])/\n/;t' <<< "text12-01-2016"