use strict;
my $str = 'text12-01-2016';
my $regex = qr/(?<=[a-zA-Z])(?=[0-9])/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";