const regex = /(?<=[a-zA-Z])(?=[0-9])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[a-zA-Z])(?=[0-9])', '')
const str = `text12-01-2016`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);