$re = '/(?<=[a-zA-Z])(?=[0-9])/';
$str = 'text12-01-2016';
$subst = "\n";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;