import Foundation
let pattern = #"(?<=[a-zA-Z])(?=[0-9])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"text12-01-2016"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}